روش اتصال به سوییچ از طریق SSH

روش اتصال به سویچ از طریق ssh

روش اتصال به سوییچ از طریق SSH

روش اتصال به سوییچ از طریق SSH

گروه اموزشی ما شوید روی لینک پایین کلیک کنید

لینک گروه اموزشی شبکه

کانال آموزش های رایگان شبکه و سیسکو 

switch>enable

switch#configure terminal

Switch(config)#interface vlan 1

Switch(config-if)#no shutdown

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#exit Switch(config)#username ali secret 1234p@

Switch(config)#line vty 0 15

Switch(config-line)#login local

Switch(config-line)#exit

Switch(config)#enable password 1234

یا

Switch(config)#enable secret 123456P@

Switch(config)#line vty 0 15

Switch(config-line)#transport input all

Switch(config)#ip domain-name mcseha.ir

How many bits in the modulus [512]: 512


روش اتصال به سوییچ از طریق SSH

ssh از دوتا کلید استفاده میکند یکی پابلیک کی و پرایوت کی

publik key و private key

پابلیک را میده به کامپیوتری که قراره بهش ssh بزنیم یعنی قفل میکند و برای ما میفرستد

برای ssh زدن عین تلنت TELNET است و فقط سه چهار اپشن اضاف تر دارد

en

conf t

interface vlan 1

ip address 192.168.10.100 255.255.255.0

no shut down

مد enable حتما باید پسورد داشته باشد

enable secret 123

تا اینجا هیچ فرقی با تلنت نکرد

توی تلنت طرف وقتی میخواهیم وصل شویم هم با یوزر نیم میتونیم وصل شویم هم با پسورد

یعنی میتوانیم با پسورد فقط وارد شود و هم میتوانیم با login local وصل شویم

ولی توی ssh فقط login local داریم

لازمه login local یوزره

username ali secret 123

line vty 0 4

login local

دستورات ssh زدن

transport input ?

all

none

ssh

telnet

ما باید فقط پورت ssh را باز کنیم

یعنی transport input ssh

یعنی الان فقط ssh میتوانیم بزنیم تلنت نمی توانیم بزنیم

توی مد کانفیگ باید کلید درست کنیم

conf t

کلید پابلیک و پرایوت بسازیم یعنی با rsa کلید میسازیم

crypto key genrate rsa

یعنی از الگوریتم rsa برای من کلید بساز

حتما باید هاست نیم یه اسم غیر از switch باشه

این سیکو که برا هاست نیم گذاشتیم در واقع اسم فلته و یه اسم fqdn دیگر باید براش بسازیم

ip domain-name mcseha.ir

الان میتونیم کلید جنریت کنیم

کلید 512 را انتخاب میکنیم چون ساختش زودتر انجام میشود ولی 1024 ممکنه یکم طول بکشه

و در نهایت دستور

ssh -L ALI 192.168.10.100


نمایش کلید هایی که برای ssh جنریت شده اند

با دستور show ceypto key mypubkey rsa

با استفاده از این دستور دوتا کلید را نمایش میدهد

6 Replies to “روش اتصال به سوییچ از طریق SSH

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد.