اتصال به سوئیچ سیسکو از طریق telnet

اتصال-به-سوئیچ-سیسکو-از طریق telnet

اتصال به سوئیچ سیسکو از طریق telnet

چطور به سویچ سیسکو تلنت بزنیم

حتما وارد گروه اموزشی ما شوید روی لینک پایین کلیک کنید

لینک گروه اموزشی شبکه

کانال آموزش های رایگان شبکه

تلنت یک اپلیکیشن است و از نوع tcpاست و پورت 23 است

یعنی ما باید این لایه ها را رعایت کنیم و این لایه ها را یکی یکی بیام پایین یعنی ایپی بعد مک و …

تلنت TELNET و SSH   پروتوکلی ایست برای مدیریت و منیج کردن سویچ های سیسکو

آموزش کامل telnet به صورت فیلم

دانلود فیلم آموزشی telnet به صورت کامل

دستورات telnet 

Switch#en

Switch#conf t

Switch(config)#username mcseha secret 123

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.10.10 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#line vty 0 4

Switch(config-line)#username mcseha secret 123

Switch(config)#login local

کانال اموزش سیسکو

اگر ما چند تا سویچ داشته باشیم و بخواهیم به سویچ اخری که یک سیستم کانفیگ نشد مثلا پورتش خاموش است تلنت بزنیم و کانفیگش کنیم از راه دور

چطور به سویچ تلنت telnet  بزنیم
چطور به سویچ تلنت telnet بزنیم

ما باید همه لایه ها را چک کنیم تا به لابه فیزیکال برسیم

مک همه این ها داخل یه برادکست هستند

اون سویج بایدآیپی داشته باشه تا ما بهش ختم بشیم

اینترفیس های لایه دو سویچ اصلا ایپی ادرس ندارند یعنی ایپی نمیگیرد

ما اول برای کامپیوتری که میخواهیم ازش تلنت بزنیم ایپی ست میکنیم

vlan1

در سویچ های سیسکو یک اینترفیس لایه سوم وجود دارد و خاموش است

در سویچ دو تا کامپیوتر ممکن است در لایه سه ارتباط نداشته باشند ولی در لایه دو حتما ارتباط دارند چون همه برادکست هاشون به هم میرسند arp میشوند

چون این کامپیوتر ها جز virtual lan هستند یعنی vlan هستند

vlan 1

در سویچ های سیسکو تمام پورت های سویچ عضو یک vlan هستند که به ان vlan 1 میگویند

ما با vlan این کامپیوتر ها را جدا میکنیم و همدیگر را نمی توانند ببینند

یعنی ما با vlan می توانیم سویچ مان را جدا کنیم یعنی یک سویچ را دو تا سویچ گنیم یعنی دیگه هیچ ارتباطی بهم ندارند

به خاطر همین است که ما کابل ها را که وصل میکنیم همه با همدیگر ارتباط دارند به خاطر اینه که نوی یه vlan هستند

حالا این اینترفیس لایه سه ما که خاموش است به vlan 1 وصله

ما باید روی اینترفیس لایه سه ما ایپی ست کنیم بعد از حالت shutdown درش میاریم

حالا وقتی از کامپیوتری که بخوام به سویچ تلنت بزنیم دنبال ایپی اینترفیس ما میگرده یعنی ارپ arp میکنه

interface vlan خودش مک داره

مک را بر میگرداند و در نتیجه همدیگر را پینگ میکنند

نحوه تلنت زدن به سویچ سیسکو
نحوه تلنت زدن به سویچ سیسکو

دانلود فیلم آموزشی telnet به صورت کامل


اتصال به سوئیچ سیسکو از طریق telnet

توی مد کانفیگ vlan 1 را صدا میزنیم

conf t

interface vlan 1

دستور ست کردن آیپی روی vlan 1

ip address 192.168.10.100 255.255.255.0

حالا کامپیوتری که میخوام تلنت ازش بزنیم را هم ایپی میدهیم ایپی 192.168.10.1 میدهیم

vlan 1 m be up

و اینترفیس های لایه دو به محض اینکه کابل میزنیم روشن میشوند

interface vlan 1
Switch(config-if)#ip address 192.168.10.100 255.255.255.0

Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

ما زمانی میتوانیم تلنت بزنیم که با سویچ ارتباط داشته باشیم


موقعی که تلنت میزنیم میریم توی یوزر مد

قبلا چطور می اومدیم توی یوزر مد از طریق کابل می اومدیم حالا این vlan وسط است وما باید از طریق یک در وارد شویم و به یوز مد برویم که به این در ها می گویند vty virtual teletype یعنی باید برویم توی لاین vty

وقتی که کابل کنسول می زدیم میرفتیم سراغ لاین کنسول حالا به جاش ما باید از لاین vty استفاده کنیم

vty

و به محض اینکه پسورد بزاریم روی این در ها فعال میشوند


لاین های vty

لاین های vty 0-15 تا داریم یعنی به این لاین ها میتونن 16 تا ادمین همزمان تلنت بزنند

لاین ها 0-4 لاین های قدیمی هستند و 5 تا 15 لاین های جدید هستند

line vty 0

password 123

Switch(config)#line vty 0
Switch(config-line)#password 123
Switch(config-line)#


line vty 0 یعنی اولین درب است

اگر یه نفر ادمین هست vty 0 و اگر ن تا ادمین هستید بستگی به تعداد ادمین ها داره

برای تلنت زدن باید توی مد کامند پرامپت کلمه تلنت و ادرس ایپی سویچ را بزنیم ولازمه تلنت زدن باید مد enable هم پسورد داشته باشد

لاین vty و کنسول سکرت secret ندارند

باید یوزر نیم تعریف کنی براشون تا سکرت بشن

 

username ali secret 123

login local


PC>telnet 192.168.10.100
Trying 192.168.10.100 …Open

User Access Verification

Password:
Switch>456
Translating “456”…domain server (255.255.255.255)
% Unknown command or computer name, or unable to find computer address

Switch>en
Password:
Switch#

دستور show user

این دستور تعداد یوزر های ما را نمایش میدهد

تفاوت پروتکل telnet و ssh

 

دانلود فیلم آموزشی telnet به صورت کامل

تفاوت پروتکل telnet و ssh
تفاوت پروتکل telnet و ssh



کانفیگ از طریق تلنت از لحاظ امنیتی کار درستی نیست و شما حتما از ssh استفاده کنید با یه سری نرم افزار ها هک hack تلنت کاملا اسنیف میشود

23 Replies to “اتصال به سوئیچ سیسکو از طریق telnet

  1. یه سوئیچ هست روش telnet راه اندازی کردن 10تا سیستم بهش وصله حالا میخوان فقط ۲ تا از این سیستم ها بهش telnet بزنن باید چیکار کنم

    1. تلنت رو فعال سازی کن بعد یک اکسس لیست بنویس بگو دوتا ای پی مورد نظر رو اعمال کن و از ssh استفاده کن به جای تلنت

  2. سلام
    براي بستن تل نت telnet تو ميكروتيك از بيرون شبكه رولشو چه جوري مينويسن؟؟
    براي بستنش تو داخل شبكه را بلدم؟
    جه جوري مشحص كنم كه يوزر از بيرون داره تل نت ميزنه !!!
    منظورم سورس ادرسو جي بزنم؟
    واسه داحل كه رنج شبكم هست!!

    1. همون سر برگ. General. در فایروال میکروتیک.
      In interface
      رو اینترفیس اینترنت انتخاب کنید
      Ip – service – disable telnet

  3. من تو یک شبکه محلی عمل Telnet رو انجام میدم اما کانکت نمیشه فایروال هردو سیستم هم خاموش هست…مشکل از چی میتونه باشه

  4. سلام وقتی به سوییچ تلنت می زنم در ارتباط telnet چه جوری آدرس ipسوییچ رو بفهمیم از طریق کدوم دستور

  5. سلام مدیر شبکه می خواد روی تمام دیوایس ها از طریق telnet دسترسی داشته باشه
    باید دستور تلنت رو روی کدوم دیوایس ها کانفیک کنم؟یه سوییچ لایه سه هم هست که به عنوان سرور ازش استفاده میکنم و تمام ویلن ها روی اونه. باید تکی هر دیوایس را کانفیگ telnet کنیم یا نیازی نیست

  6. سلام مهندس
    چجوری من تلنت بزنم یعنی میخوام نفوذ به میکروتیک از داخل شبکه داشته باشم چه روش ها راه هایی برای نفوذ به میکروتیک هست راحت باشه در یک شبکه از طریق سوییچ (هاب) به میکروتیک متصل هستیم

  7. دستوری هست که توی سوئیچ های سیسکو بزنیم ببینیم مثلا username و پسورد اون موقع telnet یا ssh زدن چیه یا اصلا یک دستوری وجود داره که یک line vty رو پاک کنه

  8. استاد وقتی میخوام ازputty
    Telnet بزنم
    ارور connection refused میده مشکل چیه
    ممنون از سایت خوبتون

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد.